setText in Windows App: Operation not supported/Target not found


i developed an access form which contains two edit text fields. i want to set a text in textfeld using ORQA.

When i use setText in Windows App , then select xpath: Xpath will be reconginited automatically.
I got following Error when i run my programm : Operation not supported.
Press Key in Windows App works fine with same xpath as previous.
i tried to define my xpath using name, x,y coordination, height and width.
When i write my modified xpath in ui explorer then search, it is found.
when i run my program, i get target not found.
Following is weird for me: When i use press a key in my windows app, it works fine.
i do not get errors: target not found / operation not supported.

Any Tipps?

Best regards,

Hi Ahm,

Could you give us a bit more information about what kind of of control you’re using in Access? Even a screenshot would help for now. Thanks!



i would like to write something in textfeld. As mentioned before press key in windows app works fine for me.For example A B C then ABC will be shown but if if i want to write the whole Text ABC
setText in Windows App. i get Operation not supported
As shown in picture when i press key in windows app for example b , b will shown. which explains that xpath is right


BTW what version of MS Access are you using? Thanks!


Access 2013

Hi, We’re looking into it. We’ll have to setup an environment as close to what you have as possible to be able to replicate so please bear with us. Thanks


So i am using Windows 8.
Access 2013
ORQA version 20161115 (last one )

Best regards,